FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC

Développement d'applications avec le langage Panoramic
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  
Derniers sujets
» mise a jour calculatrice
par JL35 Aujourd'hui à 14:14

» [solved] 3D_LINE How to ?
par papydall Aujourd'hui à 6:51

» supprimé
par joeeee2017 Dim 15 Oct 2017 - 20:02

» calculatrice avec touches movibles
par joeeee2017 Dim 15 Oct 2017 - 1:11

» Convertisseur de base 10 de 2 à 36
par gigi75 Sam 14 Oct 2017 - 21:54

» CORTANA
par gigi75 Sam 14 Oct 2017 - 16:32

» supprimé
par Jean Claude Sam 14 Oct 2017 - 12:30

» Compilateur FBPano
par jean_debord Jeu 12 Oct 2017 - 9:53

» KGF_dll - nouvelles versions
par Klaus Mar 10 Oct 2017 - 18:49

» à propos de Panoramic_Editor [Résolu]
par Klaus Mar 10 Oct 2017 - 3:19

» Un petit "coucou" à tous les Panoramiciens !
par Jack Ven 6 Oct 2017 - 10:24

» Pourquoi le compilateur stagne
par mindstorm Mer 4 Oct 2017 - 20:38

» Panoramic ?
par Marc37 Mer 4 Oct 2017 - 0:39

» Premiers pas avec Arduino
par Marc37 Mer 4 Oct 2017 - 0:29

» Mise à jour PANOMAND
par jean_debord Mar 26 Sep 2017 - 11:33

Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Octobre 2017
LunMarMerJeuVenSamDim
      1
2345678
9101112131415
16171819202122
23242526272829
3031     
CalendrierCalendrier

Partagez | 
 

 File_move (résolu, je crois)

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
jjn4

avatar

Nombre de messages : 1601
Date d'inscription : 13/09/2009

MessageSujet: File_move (résolu, je crois)   Sam 26 Aoû 2017 - 18:56

Un petit bonjour des vacances...
(mais je n'ai pu m'empêcher de faire
un peu de panoramic, aïe, aïe, aïe)

La question que je pose est celle-ci :
Est-il normal que si je fais :
Code:
file_move "D:\noel.bmp","D:\Temp\noel.bmp"
ça marche, ça déplace la photo
Et si je fais :
Code:
file_move "C:\noel.bmp","C:\Temp\noel.bmp"
ça ne marche pas ?
File_move serait-il allergique à la lettre C ?
(alors qu'avec File_copy, ça marche)
(on dirait bien que j'ai débusqué un bug)
scratch alien scratch
(qu'en dit le forum (très en vacances ces temps-ci...?))
(à bientôt... enfin, pas tout de suite!)
sunny alien sunny
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://jjn4.e-monsite.com
jjn4

avatar

Nombre de messages : 1601
Date d'inscription : 13/09/2009

MessageSujet: Re: File_move (résolu, je crois)   Sam 26 Aoû 2017 - 19:42

Oups, je crois bien que j'ai trouvé ce qui ne va pas
et que le mot-clé File_move n'a pas de bug.
Ca pourrait être dû à cette saloperie de sécurité
de l'ordinateur, mais pas simple, quand même
parce que ça peut le faire aussi avec des sous-répertoires...
scratch alien scratch


Dernière édition par jjn4 le Dim 27 Aoû 2017 - 16:16, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://jjn4.e-monsite.com
JL35



Nombre de messages : 5952
Localisation : 77
Date d'inscription : 29/11/2007

MessageSujet: Re: File_move (résolu, je crois)   Sam 26 Aoû 2017 - 20:52

Salut jj,

C'est curieux ton affaire, chez moi ça marche très bien (transfert d'un fichier txt de C:\ vers C:\TEMP).
  file_move "C:\rapport.txt","C:\Temp\rapport.txt"
Le fichier est bien déplacé.

Par contre, ce qui est curieux, si je recommence (le fichier émetteur n'existe plus), eh bien je n'ai pas d'erreur !
Et même plus:
   file_move "K:\Bidule","C:\Temp\rapport.txt"
évidemment il ne se passe rien, mais pas d'erreur non plus... scratch
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jjn4

avatar

Nombre de messages : 1601
Date d'inscription : 13/09/2009

MessageSujet: Re: File_move (résolu, je crois)   Dim 27 Aoû 2017 - 16:15

Salut JL35 :
JL25 a écrit:
C'est curieux ton affaire...
C'est sur un W10 dernier cri hyper sécurisé qui fait des tas de difficultés
lorsqu'on veut ajouter un fichier en C: ou en effacer un. Ca doit être pour ça.

JL35 a écrit:
mais pas d'erreur non plus...
Apparemment, il accepte tout type d'anomalie
sauf que le fichier à déplacer soit déjà présent à l'adresse de destination.
A+
sunny elephant alien flower afro
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://jjn4.e-monsite.com
JL35



Nombre de messages : 5952
Localisation : 77
Date d'inscription : 29/11/2007

MessageSujet: Re: File_move (résolu, je crois)   Dim 27 Aoû 2017 - 21:35

Bonsoir jj,
C'est probable qu'il y a un problème de protection à la racine du disque, surtout avec W10 (je suis toujours sous 7, j'attends d'être forcé de basculer...).
Mais ce n'est pas très normal qu'il n'y ait pas d'erreur signalée par Panoramic si on demande à déplacer un fichier qui n'existe pas !
L'erreur est pourtant prévue dans la doc de la fonction FILE_MOVE F1,F2, erreur si:
- le fichier F1 n'existe pas
- le fichier F2 existe déjà
- F1 ou F2 n'est pas un nom correct de fichier.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: File_move (résolu, je crois)   

Revenir en haut Aller en bas
 
File_move (résolu, je crois)
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [Résolu] Croix rouge à la place d'une image
» [Résolu] Mot de passe smtp
» [Résolu] MSN vérolé
» [résolu]pc infecté par wwwzuc32.exe
» [Résolu] Photoshop CS2 : tampon

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC :: PANORAMIC :: Un bug dans PANORAMIC?-
Sauter vers: