FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC

Développement d'applications avec le langage Panoramic
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  
Derniers sujets
» Planétarium virtuel.
par Pedro Alvarez Aujourd'hui à 16:57

» Roues dentées
par jean_debord Aujourd'hui à 10:40

» Attention arnaque !
par mindstorm Jeu 19 Juil 2018 - 19:18

» Qui fait quoi ?
par silverman Mer 18 Juil 2018 - 15:21

» ITEM_SELECT N,L pour synedit
par silverman Mer 18 Juil 2018 - 15:20

» Boussole
par jean_debord Mer 18 Juil 2018 - 11:06

» Roue à n faces
par Marc Dim 15 Juil 2018 - 22:16

» Exemple d'une nouvelle version d'un GRID
par Jean Claude Ven 13 Juil 2018 - 10:32

» Une simple question
par Oscaribout Sam 7 Juil 2018 - 23:20

» BUG sur l'objet TAB
par Jack Sam 7 Juil 2018 - 21:12

» Monopoly moderne
par jjn4 Sam 7 Juil 2018 - 15:06

» Récapitulatif ludothèque panoramic jjn4
par jjn4 Ven 6 Juil 2018 - 17:41

» Lignes ondulées
par JL35 Ven 6 Juil 2018 - 17:39

» bug off_activate 0 : sans d'effet
par silverman Ven 6 Juil 2018 - 13:02

» Position des objets d'un conteneur dans FBPano et Panoramic
par Navigateur Ven 6 Juil 2018 - 12:59

Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Juillet 2018
LunMarMerJeuVenSamDim
      1
2345678
9101112131415
16171819202122
23242526272829
3031     
CalendrierCalendrier

Partagez | 
 

 Problème de lancement de programme.

Aller en bas 
AuteurMessage
Pedro Alvarez

avatar

Nombre de messages : 1104
Date d'inscription : 19/01/2014

MessageSujet: Problème de lancement de programme.   Ven 31 Mar 2017 - 16:55

Bonjour.

Mon programme principal, qui comporte maintenant 46.235 lignes, fonctionnait parfaitement jusqu'à présent.

Or, à l'exécution, j'obtiens aujourd'hui le message d'erreur suivant:

(13) More WHILE than ENd_WHILE !

C'est incompréhensible.

J'ai donc vérifié avec le code suivant, et la valeur retournée pour b% est identique à celle de c%.

Code:
dim a$, k%, b%, c%

file_open_read 1,"langues.bas"

for k%=1 to 46235
    file_readln 1,a$
    a$=trim$(a$)
    if left$(a$,6)="while " then b%=b%+1
    if left$(a$,9)="end_while" then c%=c%+1
next k%

file_close 1
message str$(b%)+" : "+str$(c%)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème de lancement de programme.   Ven 31 Mar 2017 - 17:18

Teste plutôt comme ceci:
Code:
dim a$, k%, b%, c%

file_open_read 1,"langues.bas"

for k%=1 to 46235
    file_readln 1,a$
    a$=lower$(trim$(a$))  : ' <========= tenir compte d'éventuelles majuscules !
    if left$(a$,6)="while " then b%=b%+1
    if left$(a$,9)="end_while" then c%=c%+1
next k%

file_close 1
message str$(b%)+" : "+str$(c%)

Et encore - ça ne prend pas en compte des WHILE ou END_WHILE qui seraient dans une ligne de continuation (après un signe ":").

Une meilleure méthode, brutale mais efficace, serait de tester par morceaux. Travaille sur une copie de ton code, par sécurité. Puis, coupe une partie (à partir de la fin, de préférence) et relance-le. Certes, ce ne sera pas opérationnel. Mais le test sur la cohérence des WHILE/END_WHILE se fait avant le vrai lancement du programme. Et dès que tu n'as plus ce message d'erreur, tu sais que l'anomalie est dans la partie éliminée.

Bonne chance !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Pedro Alvarez

avatar

Nombre de messages : 1104
Date d'inscription : 19/01/2014

MessageSujet: Problème de lancement de programme.   Ven 31 Mar 2017 - 20:20

Bonsoir.

Merci Klaus, j'ai donc procédé ainsi, afin de pouvoir détecter l'erreur.
Et je l'ai trouvée !

Panoramic ne détecte pas les blancs éventuels situés juste après un 'end_while'.

Exemple:

end_while...

Les '.' correspondant à des blancs, difficiles à détecter.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème de lancement de programme.   Ven 31 Mar 2017 - 22:31

De rien, Pedro ! Des incohérences sur des While, Select, If, Sub etc, j'en ai souvent, et j'utilise la méthode indiquée pour les dépister. Toute expérience est bonne à partager.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Contenu sponsorisé




MessageSujet: Re: Problème de lancement de programme.   

Revenir en haut Aller en bas
 
Problème de lancement de programme.
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» problème avec odomètre de trajet sur oregon 450 [résolu]
» Erreur java affichage didacticiel fourni avec E-Anim
» problème démarrage
» [Résolu] Problème avec psg tv
» Problème avec roll over qui "clignote"

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC :: PANORAMIC :: A l'aide!-
Sauter vers: