FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC

Développement d'applications avec le langage Panoramic
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  
Derniers sujets
» Découpe dans une image
par JL35 Aujourd'hui à 23:03

» FNC IsDateValide(d$) pour vérifier la validité d'une date
par Marc Aujourd'hui à 21:51

» Pour faire plaisir à Marc37.
par Marc Aujourd'hui à 21:46

» Couleur d'une variable qui n'est pas un mot-clé
par bignono Aujourd'hui à 14:03

» Un catalogue de photos de fleurs, avec KBDD, affichage HTML
par Klaus Hier à 22:44

» KGF_dll - nouvelles versions
par Klaus Hier à 22:30

» Mah-Jong anglais
par jjn4 Hier à 14:22

» Partie fractionnaire d'un flottant
par silverman Hier à 14:19

» bug CREATE_HIDE : corruption de form
par silverman Hier à 13:32

» Racine carrée d’un nombre par l’algorithme de Héron
par Ouf_ca_passe Hier à 9:52

» Méthode manuelle d'extraction de la racine carrée
par pascal10000 Hier à 7:47

» [annulé]ON_MOVE n,l ne fonctionne que sur le form 0
par silverman Mar 20 Fév 2018 - 16:52

» Ludothèque Panoramic
par jjn4 Mar 20 Fév 2018 - 15:42

» Calculus
par Ouf_ca_passe Mar 20 Fév 2018 - 9:06

» 6 (en analyse):confusion de variable locale entre SUB et FNC
par Jack Mar 20 Fév 2018 - 8:18

Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Février 2018
LunMarMerJeuVenSamDim
   1234
567891011
12131415161718
19202122232425
262728    
CalendrierCalendrier

Partagez | 
 

 Bizarre bizarre est-ce un bug du langage ? (résolu)

Aller en bas 
AuteurMessage
jjn4

avatar

Nombre de messages : 1679
Date d'inscription : 13/09/2009

MessageSujet: Bizarre bizarre est-ce un bug du langage ? (résolu)   Ven 15 Avr 2016 - 16:39

Voici un premier mini programme
(qui est une partie d'un programme plus vaste que je concocte)
qui fonctionne normalement :
Lorsque vous sélectionnez un texte dans un combo ou un edit
et que vous cliquez sur le form 0
vous obtenez le numéro de l'objet-système qui contient le texte sélectionné.
Essayez, d'ailleurs, et vous vous direz : rien d'anormal jusque là !
Code:
dim i% , j%
label go
alpha 5
   top 5,50
' button 10
'    top 10,100
  
on_click 0,go

for i%=640 to 760 step 20
   if i%<>720
      combo i%
         left i%,((i%/20)-32)*60
         width i%,50
         item_add i%,"azerty"
   end_if
next i%
edit 780
   left 780,420
alpha 900
   top 900,200
   caption 900,"Cliquez ici -->"
end
go:
   j%=0
   for i%=640 to 780 step 20
      if i%<>720
         if select_read$(i%)<>""
            j%=i%
            exit_for
         end_if
      end_if
   next i%
   caption 5,j%
return
Et maintenant, vous rajoutez un bouton
et ça se met à fonctionner bizarrement,
plus avec les combo qu'avec edit.
Quelqu'un aurait une explication ?
Code:
dim i% , j%
label go
alpha 5
   top 5,50
button 10
   top 10,100
   caption 10,"Cliquez ici"
  
on_click 10,go

for i%=640 to 760 step 20
   if i%<>720
      combo i%
         left i%,((i%/20)-32)*60
         width i%,50
         item_add i%,"azerty"
   end_if
next i%
edit 780
   left 780,420
end
go:
   j%=0
   for i%=640 to 780 step 20
      if i%<>720
         if select_read$(i%)<>""
            j%=i%
            exit_for
         end_if
      end_if
   next i%
   caption 5,j%
return
scratch scratch scratch scratch scratch scratch alien scratch scratch scratch scratch scratch scratch
BN: Tiens, et si je remplace le button par un panel, ça fonctionne bien,
de plus en plus bizarre...!
scratch No alien No scratch


Dernière édition par jjn4 le Sam 16 Avr 2016 - 18:01, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://jjn4.e-monsite.com
Marc



Nombre de messages : 632
Age : 57
Localisation : TOURS
Date d'inscription : 17/03/2014

MessageSujet: Re: Bizarre bizarre est-ce un bug du langage ? (résolu)   Ven 15 Avr 2016 - 22:17

Bonsoir Jjn4,

Je confirme, chez moi, le même dysfonctionnement.
Dans ton 2ème source, l'instruction SELECT_READ$ ne lit pas les COMBOs ! ! ? ?

Et..., je n'ai pas d'explication !

Attendons les autres tests et avis.

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Marc



Nombre de messages : 632
Age : 57
Localisation : TOURS
Date d'inscription : 17/03/2014

MessageSujet: Re: Bizarre bizarre est-ce un bug du langage ? (résolu)   Ven 15 Avr 2016 - 22:50

Suite ...

Si tu utilises juste avant SELECT_READ$ la fonction SELECT_TEXT, ça fonctionne.

Ce qui donne :
Code:
go:
   j%=0
   for i%=640 to 780 step 20
      if i%<>720
         SELECT_TEXT i%,1,20
         if select_read$(i%)<>""
            j%=i%
            exit_for
         end_if
      end_if
   next i%
   caption 5,j%
return

Dans cet exemple, je n'ai sélectionné que les 20 premiers caractères.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
silverman

avatar

Nombre de messages : 525
Age : 45
Localisation : Picardie
Date d'inscription : 18/03/2015

MessageSujet: Re: Bizarre bizarre est-ce un bug du langage ? (résolu)   Sam 16 Avr 2016 - 10:20

A mon avis, ce n'est pas un dysfonctionnement.
Dès que tu cliques sur le bouton, le combo perd le focus, du coup 'select_read' ne vois plus rien.
Sous panoramic_editor, regarde dans aide puis evénements, tu verras ce que le combo peu détecter comme événements qui peu te servir(le 'on_change' devrait te plaire Very Happy .
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jjn4

avatar

Nombre de messages : 1679
Date d'inscription : 13/09/2009

MessageSujet: +++   Sam 16 Avr 2016 - 14:22

Merci, Marc37, pour les possiblités avec le select_text,
mais ce n'est pas le but de mon programme qui consiste
à déterminer le choix de l'utilisateur du programme.

Je pense qu'il s'agit bien d'un dysfonctionnement,
puisque lorsque je mets un panel en guise de bouton,
ça fonctionne très bien.
Je pense donc que le select_read$ est incompatible avec les boutons.

Exemple du programme 2 ci-dessus, mais avec un panel
Code:
dim i% , j%
label go
alpha 5
   top 5,50
panel 10
   top 10,100
   caption 10,"Cliquez ici"

on_click 10,go

for i%=640 to 760 step 20
   if i%<>720
      combo i%
         left i%,((i%/20)-32)*60
         width i%,50
         item_add i%,"azerty"
   end_if
next i%
edit 780
   left 780,420
end
go:
   j%=0
   for i%=640 to 780 step 20
      if i%<>720
         if select_read$(i%)<>""
            j%=i%
            exit_for
         end_if
      end_if
   next i%
   caption 5,j%
return
Suspect alien Suspect
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://jjn4.e-monsite.com
Klaus

avatar

Nombre de messages : 10575
Age : 68
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Bizarre bizarre est-ce un bug du langage ? (résolu)   Sam 16 Avr 2016 - 14:29

Cela ne contredit pas ce que suggère Silverman. Un panel ne peut recevoir de focus. Essaie plutôt avec un EDIT ou un MEMO.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
silverman

avatar

Nombre de messages : 525
Age : 45
Localisation : Picardie
Date d'inscription : 18/03/2015

MessageSujet: Re: Bizarre bizarre est-ce un bug du langage ? (résolu)   Sam 16 Avr 2016 - 14:52

voila une version modifié et fonctionnelle de ton code avec un bouton, qui confirme cette histoire de focus:
Code:

dim i% , j% ,hwndF%, hwnd%
label go,checkfocus
alpha 5
   top 5,50
button 10
   top 10,100
   caption 10,"Cliquez ici"

on_click 10,go

for i%=640 to 760 step 20
   if i%<>720
      combo i%
         left i%,((i%/20)-32)*60
         width i%,50
         item_add i%,"azerty"
         on_change i%,checkfocus
   end_if
next i%
edit 780
   left 780,420
  
   dll_on "user32"
END
'
checkfocus:
   hwndF%=dll_call0("GetFocus")
return

go:
hwnd%=dll_call1("SetFocus",hwndF%)
   j%=0
   for i%=640 to 780 step 20
      if i%<>720
         if select_read$(i%)<>""
            j%=i%
            exit_for
         end_if
      end_if
   next i%
   caption 5,j%
return
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Marc



Nombre de messages : 632
Age : 57
Localisation : TOURS
Date d'inscription : 17/03/2014

MessageSujet: Re: Bizarre bizarre est-ce un bug du langage ? (résolu)   Sam 16 Avr 2016 - 16:38

Je viens de tester la solution de Silverman et de la version Jjn4 avec PANEL, je ne vois aucune différence de fonctionnement avec la solution que j'ai proposée plus haut :
Ajout de SELECT_TEXT i%,1,20 juste avant if select_read$(i%)<>"".
Le résultat semble strictement identique.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jjn4

avatar

Nombre de messages : 1679
Date d'inscription : 13/09/2009

MessageSujet: +++   Sam 16 Avr 2016 - 17:45

Oui, oui, je vois la différence,
un bouton « s'enfonce » et donc capte le focus avant d'exécuter ce pourquoi on le programme
alors que le panel ne « bouge » pas et n'empêche pas le focus d'être capté au niveau du combo ou de l'edit.
Pffff, vilains boutons !
Laughing
Merci, Silverman, mais comme ton truc marche avec les combo mais pas avec les edit,
je vais tout simplement garder des panel en guise de bouton, dans mon programme.
Donc, effectivement, ce n'est pas un bug.
Merci à tout le monde !
cheers alien cheers
Je vous posterai prochainement mon programme quand il sera fini...
tongue alien tongue
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://jjn4.e-monsite.com
silverman

avatar

Nombre de messages : 525
Age : 45
Localisation : Picardie
Date d'inscription : 18/03/2015

MessageSujet: Re: Bizarre bizarre est-ce un bug du langage ? (résolu)   Dim 17 Avr 2016 - 12:28

Bien sur que si ça marche, mais il faut utiliser un 'on_click' à la place du 'on_change':
Code:

dim i% , j% ,hwndF%, hwnd%
label go,checkfocus
alpha 5
  top 5,50
button 10
  top 10,100
  caption 10,"Cliquez ici"

on_click 10,go

for i%=640 to 760 step 20
  if i%<>720
'      combo i% : item_add i%,"azerty"
      edit i% : text i%,"azerty"
        left i%,((i%/20)-32)*60
        width i%,50
'        on_change i%,checkfocus
        on_click i%,checkfocus
  end_if
next i%
edit 780
  left 780,420

  dll_on "user32"
END
'
checkfocus:
  hwndF%=dll_call0("GetFocus")
return

go:
hwnd%=dll_call1("SetFocus",hwndF%)
  j%=0
  for i%=640 to 780 step 20
      if i%<>720
        if select_read$(i%)<>""
            j%=i%
            exit_for
        end_if
      end_if
  next i%
  caption 5,j%
return
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jjn4

avatar

Nombre de messages : 1679
Date d'inscription : 13/09/2009

MessageSujet: +++   Dim 17 Avr 2016 - 16:03

Ah, c'est super !
bounce alien bounce
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://jjn4.e-monsite.com
Contenu sponsorisé




MessageSujet: Re: Bizarre bizarre est-ce un bug du langage ? (résolu)   

Revenir en haut Aller en bas
 
Bizarre bizarre est-ce un bug du langage ? (résolu)
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [Résolu] OE6 : message bizarre
» Chemin d'accès très bizarre [RESOLU]
» erreur bizarre [RESOLUT]
» phenomene bizarre !
» Bruit bizarre suite à le MAJ

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC :: PANORAMIC :: A l'aide!-
Sauter vers: