FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC

Développement d'applications avec le langage Panoramic
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  
Derniers sujets
» Rotation d'une image d'un angle quelconque
par JL35 Aujourd'hui à 14:26

» StratégoV8 et V9
par Jean Claude Aujourd'hui à 14:22

» GRID_LOAD
par Jean Claude Hier à 21:04

» HVIEWER
par Yannick Hier à 20:31

» KGF_dll - nouvelles versions
par Klaus Mar 16 Jan 2018 - 21:28

» Déformation d'image en trapèze
par mindstorm Mar 16 Jan 2018 - 21:06

» Mah-Jong américain
par Jean Claude Lun 15 Jan 2018 - 19:37

» Problème avec Deepl
par Klaus Lun 15 Jan 2018 - 0:34

» Quelques nouvelles ...
par Jean Claude Ven 12 Jan 2018 - 22:40

» Renommer les instructions ITEM_... ?
par Jicehel Ven 12 Jan 2018 - 18:56

» Ludothèque Panoramic
par jjn4 Ven 12 Jan 2018 - 18:11

» sous-programmes et fonctions
par Jack Ven 12 Jan 2018 - 17:51

» Mah-Jong français
par Jean Claude Jeu 11 Jan 2018 - 22:15

» panoramic 0.9.28
par gigi75 Ven 5 Jan 2018 - 14:06

» Un jeu qui va vous énerver!
par Jean Claude Jeu 4 Jan 2018 - 22:05

Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Janvier 2018
LunMarMerJeuVenSamDim
1234567
891011121314
15161718192021
22232425262728
293031    
CalendrierCalendrier

Partagez | 
 

 bug ou pas ?...

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Yannick

avatar

Nombre de messages : 8011
Age : 46
Localisation : Bretagne
Date d'inscription : 15/02/2010

MessageSujet: bug ou pas ?...   Dim 7 Fév 2016 - 18:56

Je viens de tomber là dessus
Code:
Sub choix_mdp()
   dim_local i%
   L:
   if message_input("Choix du mot de passe","Entrer un mot de passe : ","")=1
      mdp$=message_text$
   end_if
   if len(mdp$)<8
      i%=message_warning_ok("Le mot de passe doit avoir 8 caractères !")
      goto L
   end_if
End_sub

me renvoi ceci :

(32)illegal instruction. Line 113


soit la ligne :
Code:
L:
qui est un label déclaré.... scratch


la solution que j' ai trouvé...
Code:
Sub choix_mdp()
   dim_local i%
   if message_input("Choix du mot de passe","Entrer un mot de passe : ","")=1
      mdp$=message_text$
   end_if
   if len(mdp$)<8
      i%=message_warning_ok("Le mot de passe doit avoir 8 caractères !")
      free i%
      choix_mdp()
   end_if
End_sub

Je sais, tel que, c' est une boucle infernale si on ne remplit pas correctement le champ... Wink
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
papydall

avatar

Nombre de messages : 5623
Age : 67
Localisation : Moknine (Tunisie) Entre la chaise et le clavier
Date d'inscription : 03/03/2012

MessageSujet: Re: bug ou pas ?...   Dim 7 Fév 2016 - 19:21

Ton code fonctionne chez moi.
Je l'ai complété ainsi

Code:

label l
dim mdp$
choix_mdp()
end
Sub choix_mdp()
   dim_local i%
   L:
   if message_input("Choix du mot de passe","Entrer un mot de passe : ","")=1
      mdp$=message_text$
   end_if
   if len(mdp$)<8
      i%=message_warning_ok("Le mot de passe doit avoir 8 caractères !")
      goto L
   end_if
End_sub


MAIS CESSEZ D’UTILISER GOTO  PLEASE !!!!!

Voici comment je code moi :
Code:

dim mdp$
choix_mdp()
end

Sub choix_mdp()
   dim_local i%
   repeat
   if message_input("Choix du mot de passe","Entrer un mot de passe : ","")=1
      mdp$=message_text$
   end_if
   if len(mdp$)<8
      i%=message_warning_ok("Le mot de passe doit avoir 8 caractères !")
   end_if
   until len(mdp$) >= 8
End_sub



Dernière édition par papydall le Dim 7 Fév 2016 - 19:28, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://papydall-panoramic.forumarabia.com/
Yannick

avatar

Nombre de messages : 8011
Age : 46
Localisation : Bretagne
Date d'inscription : 15/02/2010

MessageSujet: re   Dim 7 Fév 2016 - 19:25

C' est une autre solution mais cela n' explique pas l' erreur...
Laughing
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
papydall

avatar

Nombre de messages : 5623
Age : 67
Localisation : Moknine (Tunisie) Entre la chaise et le clavier
Date d'inscription : 03/03/2012

MessageSujet: Re: bug ou pas ?...   Dim 7 Fév 2016 - 19:35

Vérifie que tu as bien déclaré : LABEL L avant d’appeler la SUB.
C’est sans doute que le label n’a pas été déclaré puisque ça marche chez moi.
Voir mon 1er code ci-haut (en fait le tien que j’ai modifié)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://papydall-panoramic.forumarabia.com/
Yannick

avatar

Nombre de messages : 8011
Age : 46
Localisation : Bretagne
Date d'inscription : 15/02/2010

MessageSujet: re   Lun 8 Fév 2016 - 21:10

Effectivement, j' ai déclaré le label mais...
( Inutile de se payer ma tête  Laughing ) ...j' ai oublié de mettre le fichier des labels en #include.
Embarassed
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: bug ou pas ?...   

Revenir en haut Aller en bas
 
bug ou pas ?...
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC :: PANORAMIC :: Présentation et bavardage-
Sauter vers: