FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC

Développement d'applications avec le langage Panoramic
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  
Derniers sujets
» Traceur de courbes représentatives des fonctions y = f(x)
par Ouf_ca_passe Aujourd'hui à 20:51

» Problème de syntaxe
par Klaus Aujourd'hui à 12:40

» KGF_dll - nouvelles versions
par Klaus Aujourd'hui à 12:36

» Compilateur FBPano
par jean_debord Aujourd'hui à 12:31

» Toolbar en Panoramic
par ygeronimi Hier à 23:56

» Documentation des évènements
par Klaus Hier à 16:46

» Klaus est de retour!
par jjn4 Hier à 16:31

» Texte sur image
par Jicehel Hier à 12:23

» MIN - MAX avec SPIN
par ygeronimi Sam 21 Jan 2017 - 10:02

» HEIGHT_CLIENT(N)
par ygeronimi Ven 20 Jan 2017 - 16:41

» Non demande de commande
par ygeronimi Jeu 19 Jan 2017 - 11:50

» Bataille navale sous-marine
par papydall Jeu 19 Jan 2017 - 2:19

» Version instantanée du 16/01/2017 : PANORAMIC V 0.9.27i10
par mindstorm Mer 18 Jan 2017 - 21:05

» PLM N34
par Froggy One Mer 18 Jan 2017 - 17:32

» saving 1.png [RÉSOLU]
par Froggy One Mar 17 Jan 2017 - 19:44

Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Janvier 2017
LunMarMerJeuVenSamDim
      1
2345678
9101112131415
16171819202122
23242526272829
3031     
CalendrierCalendrier

Partagez | 
 

 bug ou pas ?...

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
ygeronimi



Nombre de messages : 7009
Age : 45
Localisation : Bretagne
Date d'inscription : 15/02/2010

MessageSujet: bug ou pas ?...   Dim 7 Fév 2016 - 18:56

Je viens de tomber là dessus
Code:
Sub choix_mdp()
   dim_local i%
   L:
   if message_input("Choix du mot de passe","Entrer un mot de passe : ","")=1
      mdp$=message_text$
   end_if
   if len(mdp$)<8
      i%=message_warning_ok("Le mot de passe doit avoir 8 caractères !")
      goto L
   end_if
End_sub

me renvoi ceci :

(32)illegal instruction. Line 113


soit la ligne :
Code:
L:
qui est un label déclaré.... scratch


la solution que j' ai trouvé...
Code:
Sub choix_mdp()
   dim_local i%
   if message_input("Choix du mot de passe","Entrer un mot de passe : ","")=1
      mdp$=message_text$
   end_if
   if len(mdp$)<8
      i%=message_warning_ok("Le mot de passe doit avoir 8 caractères !")
      free i%
      choix_mdp()
   end_if
End_sub

Je sais, tel que, c' est une boucle infernale si on ne remplit pas correctement le champ... Wink
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
papydall



Nombre de messages : 5109
Age : 66
Localisation : Moknine (Tunisie)
Date d'inscription : 03/03/2012

MessageSujet: Re: bug ou pas ?...   Dim 7 Fév 2016 - 19:21

Ton code fonctionne chez moi.
Je l'ai complété ainsi

Code:

label l
dim mdp$
choix_mdp()
end
Sub choix_mdp()
   dim_local i%
   L:
   if message_input("Choix du mot de passe","Entrer un mot de passe : ","")=1
      mdp$=message_text$
   end_if
   if len(mdp$)<8
      i%=message_warning_ok("Le mot de passe doit avoir 8 caractères !")
      goto L
   end_if
End_sub


MAIS CESSEZ D’UTILISER GOTO  PLEASE !!!!!

Voici comment je code moi :
Code:

dim mdp$
choix_mdp()
end

Sub choix_mdp()
   dim_local i%
   repeat
   if message_input("Choix du mot de passe","Entrer un mot de passe : ","")=1
      mdp$=message_text$
   end_if
   if len(mdp$)<8
      i%=message_warning_ok("Le mot de passe doit avoir 8 caractères !")
   end_if
   until len(mdp$) >= 8
End_sub



Dernière édition par papydall le Dim 7 Fév 2016 - 19:28, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://papydall-panoramic.forumarabia.com/
ygeronimi



Nombre de messages : 7009
Age : 45
Localisation : Bretagne
Date d'inscription : 15/02/2010

MessageSujet: re   Dim 7 Fév 2016 - 19:25

C' est une autre solution mais cela n' explique pas l' erreur...
Laughing
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
papydall



Nombre de messages : 5109
Age : 66
Localisation : Moknine (Tunisie)
Date d'inscription : 03/03/2012

MessageSujet: Re: bug ou pas ?...   Dim 7 Fév 2016 - 19:35

Vérifie que tu as bien déclaré : LABEL L avant d’appeler la SUB.
C’est sans doute que le label n’a pas été déclaré puisque ça marche chez moi.
Voir mon 1er code ci-haut (en fait le tien que j’ai modifié)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://papydall-panoramic.forumarabia.com/
ygeronimi



Nombre de messages : 7009
Age : 45
Localisation : Bretagne
Date d'inscription : 15/02/2010

MessageSujet: re   Lun 8 Fév 2016 - 21:10

Effectivement, j' ai déclaré le label mais...
( Inutile de se payer ma tête  Laughing ) ...j' ai oublié de mettre le fichier des labels en #include.
Embarassed
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: bug ou pas ?...   Aujourd'hui à 23:55

Revenir en haut Aller en bas
 
bug ou pas ?...
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC :: PANORAMIC 32 bits :: Présentation et bavardage-
Sauter vers: