FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC

Développement d'applications avec le langage Panoramic
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  
Derniers sujets
» [Résolu] Un prg Panoramic s'abime avec le temps (erreur)
par Oscaribout Aujourd'hui à 13:48

» Planétarium virtuel.
par Pedro Alvarez Aujourd'hui à 9:56

» Dessin 2D: largeur de trait (résolu !)
par Jicehel Hier à 15:16

» Promenade dans le Ciel
par papydall Hier à 3:13

» PanExpress : l'éditeur Panoramic avec création d'objet
par Minibug Sam 23 Juin 2018 - 17:00

» Nouvelle version 0.34
par jean_debord Sam 23 Juin 2018 - 9:39

» Quantité de mémoire utilisée par un exe
par mindstorm Jeu 21 Juin 2018 - 21:22

» Projet de planétarium virtuel.
par Jean Claude Jeu 21 Juin 2018 - 19:02

» Animation: Feux de signalisation
par Minibug Mer 20 Juin 2018 - 20:28

» Problème avec 'file_load'.
par Pedro Alvarez Lun 18 Juin 2018 - 8:12

» Version instantanée V 0.9.28i20 du 13/06/2018
par jjn4 Sam 16 Juin 2018 - 14:25

» string$(0,chr$(32)) sans erreur
par silverman Ven 15 Juin 2018 - 19:56

» Version instantanée V 0.9.28i19 du 13/06/2018
par Minibug Ven 15 Juin 2018 - 19:14

» Mes souhaits d'amélioration de Panoramic.
par Pedro Alvarez Jeu 14 Juin 2018 - 20:17

» [RÉSOLU] Message d'erreur impossible à indentifier
par Minibug Mer 13 Juin 2018 - 20:52

Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Juin 2018
LunMarMerJeuVenSamDim
    123
45678910
11121314151617
18192021222324
252627282930 
CalendrierCalendrier

Partagez | 
 

 Problème avec "DownloadFile".

Aller en bas 
AuteurMessage
Pedro Alvarez

avatar

Nombre de messages : 1069
Date d'inscription : 19/01/2014

MessageSujet: Problème avec "DownloadFile".   Mar 1 Déc 2015 - 19:28

Bonjour.

@klaus.

Je rencontre un problème avec le code suivant, lorsqu'un mot contient des caractères accentués.
Exemple, le mot "élève".
Le fichier n'est pas créé dans ce cas !

Pourtant, si res% indique bien 1.

Code:
dll_on "kgf"

dim url$, fichier$, res%, mot$

mot$="élève"
url$="http://www.systranet.com/fr/dictionary/french-english/"+mot$+"?"
fichier$=mot$+".txt"
res%=DLL_call2("DownloadFile",adr(url$),adr(fichier$))

message str$(res%)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 1:45

Et ça marche s'il n'y a pas de caractères accentués ? Je ne sais pas trop ce que tu pourrais recevoir, dans tous les cas - le contenu HTML de la page ?

Tu n'utilises pas cette fonction dans le contexte dans lequel elle doit être utilisée. Elle est prévue, comme son nom l'indique, pour télécharger un fichier dont l'URL est passée en paramètre. Et non une page. Pourquoi tu n'utilises pas
Code:
res% = DLL_call3("GetHtmlFromURL",adr(url$),handle(memo%),mode%)
Là, tu ne devrais pas avoir de problème. Le cas des caractères accentués pose un problème dès qu'ils sont codés en UTF8, ce qui est souvent las cas, sur le net.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Pedro Alvarez

avatar

Nombre de messages : 1069
Date d'inscription : 19/01/2014

MessageSujet: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 7:44

Bonjour.

Merci de ta réponse Klaus.

J'utilise la fonction suivante: res%=DLL_call2("DownloadFile",adr(url$),adr(fichier$))

Elle fonctionne très bien lorsque le nom du fichier ne contient aucun caractère accentué.

Par contre, les commandes suivantes ne fonctionnent:

url$="http://www.systranet.com/fr/dictionary/french-english/"+mot$+"?"
res%=DLL_call3("GetHtmlFromURL",adr(url$),handle(memo),1)


Merci de ton aide.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 13:02

Si, ça marche parfaitement. Voici le code complet que j'utilise:
Code:
dim res%, url$, mot$
memo 1 : full_space 1 : bar_both 1
dll_on "KGF.dll"
mot$="élève"
url$="http://www.systranet.com/fr/dictionary/french-english/"+mot$+"?"
res%=DLL_call3("GetHtmlFromURL",adr(url$),handle(1),1)
end
et tu as le code HTML dans le mémo...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Pedro Alvarez

avatar

Nombre de messages : 1069
Date d'inscription : 19/01/2014

MessageSujet: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 13:30

Bonjour.

Je te confirme que le code précédent ne fonctionne pas sur mon portable, équipé de Windows 10.
Même avec un mot non accentué.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 13:38

Je suis également sous W10. Et le code posté ci-dessus résulte en ceci (capture d'écran):

Il y a 5 à 6 secondes d'attente. Le contenu du mémo est bien sûr beaucoup plus long et ne tient pas dans les limites autorisées des posts du forum.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Pedro Alvarez

avatar

Nombre de messages : 1069
Date d'inscription : 19/01/2014

MessageSujet: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 13:43

Bonjour.

OK Klaus.

Je ne comprends pas pourquoi ce code ne fonctionne pas chez moi.
Je viens d'acquérir un nouveau portable, et j'ai le souvenir que ce code fonctionnait auparavant.

Mystère !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 16:57

Tant mieux, si c'est résolu !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Pedro Alvarez

avatar

Nombre de messages : 1069
Date d'inscription : 19/01/2014

MessageSujet: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 17:00

Bonjour.

@Klaus.

Non, désolé, mais le problème persiste toujours sur mon nouveau portable !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 17:18

Alors, j'appelle les copains à l'aide: est-ce que vous pourrez essayer ce petit code et regarder si me mémo se remplit par un code HTML ?
Code:
dim res%, url$, mot$
memo 1 : full_space 1 : bar_both 1
dll_on "KGF.dll"
mot$="élève"
url$="http://www.systranet.com/fr/dictionary/french-english/"+mot$+"?"
res%=DLL_call3("GetHtmlFromURL",adr(url$),handle(1),1)
end
Merci d'essayer...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Invité
Invité



MessageSujet: Re: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 17:54

J'ai testé, voici le retour:
Spoiler:
 

J'ai été obligé de couper, pour le retour, car j'ai le message suivant pour poster:
La longueur de votre message dépasse la limite autorisée.
Revenir en haut Aller en bas
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 18:09

Merci de ton aide, Cosmos70 ! C'est exactement ce que j'obtiens. Ce qui montre que cette fonction marche, et pas seulement chez moi.

Alors, Pedro, est-ce que cette fonction marche chez toi avec un autre mot que "élève" ? Par exemple "professeur" ? Car, ça aussi, ça marche chez moi. Si tu as toujours des problèmes, fais ceci:
1. vide ton cache internet ( important ! C'est la première mesure à prendre ! )

Si ça ne suffit pas:
2. télécharge KGF.dll à nouveau

En principe, la première mesure devrait être suffisante, sauf si ta copie de KGF.dll a été altérée. La fonction GetHtmlFromURL est ancienne et devrait marcher même si tu n'as pas la toute dernière version.

D'ailleurs, tu dis "ça ne marche pas"... Mais qu'est-ce que tu constates ? Le programme plante ? Le mémo reste vide ? Le mémo contient autre chose que le HTML de la page voulue ? Difficile d'aller plus loin dans ces conditions, surtout si ça marche ailleurs !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Pedro Alvarez

avatar

Nombre de messages : 1069
Date d'inscription : 19/01/2014

MessageSujet: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 20:10

Bonsoir.

En fait, le memo reste vide, quel que soit le mot, même non accentué.

J'ai même refait le test après avoir vidé le cache du navigateur Opera.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Marc

avatar

Nombre de messages : 796
Age : 57
Localisation : TOURS
Date d'inscription : 17/03/2014

MessageSujet: Re: Problème avec "DownloadFile".   Jeu 3 Déc 2015 - 21:15

Bonsoir à tous,

je viens d'essayer : OK chez moi :

Spoiler:
 
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème avec "DownloadFile".   Ven 4 Déc 2015 - 0:25

Là, je suis vraiment perplexe, Pedro. Et avec un autre mot, sans lettres accentués, c'est le même problème ? Dans ce cas, tu aurais peut-être un problème avec ton pare-feu qui bloquerait cette URL ou ce domaine ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Pedro Alvarez

avatar

Nombre de messages : 1069
Date d'inscription : 19/01/2014

MessageSujet: Problème avec "DownloadFile".   Ven 4 Déc 2015 - 8:09

Bonjour.

Je confirme que le problème se pose également pour des mots non accentués.

Par contre, la fonction suivante marche parfaitement, mais il subsiste un problème lorsque le mot comporte des lettres accentuées.

Pourrais-tu voir le problème ?

Code:
fichier$="c:\systran\"+mot$+".txt"
res%=DLL_call2("DownloadFile",adr(url$),adr(fichier$))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Invité
Invité



MessageSujet: Re: Problème avec "DownloadFile".   Ven 4 Déc 2015 - 8:30

J'ai pas le temps de tout relire pour voir si c'est le problème. Lorsque j'ai essayé le programme, la première fois, j'avais constamment des message me demandant une autorisation pour accepter les cookies. Les premières fois j'ai refusé, et final j'étais bloqué. Je navigue toujours en fenêtre privée, avec plein de blocage comme les cookies. J'ai recommencé en acceptant tout les cookies, et là cela a fonctionné. Il faudrait peut-être voir avec les options de ton navigateur.
Revenir en haut Aller en bas
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème avec "DownloadFile".   Ven 4 Déc 2015 - 12:40

Je répète: la fonction DownloadFile ne peut pas servir à cela. Son résultat est aléatoire si tu lui donnes une URL d'une page internet quelconque. Elle ne marche que si l'URL est celle d'un fichier (txt, jpg, pdf, etc), mais pas htm, html, xhtml etc.

Et par rapport à l'autre information:
Citation :
En fait, le memo reste vide, quel que soit le mot, même non accentué.
tu dis que tu as vidé le cache, même pour Opera. Ceci est totalement indépendant du browser et utilise directement les APIs de Windows pour gérer internet. Eventuellement, ce qui peut compter, c'est la cache Internet Explorer puisque ce sont les mêmes services qui sont en cause.

Ce qui est certain, c'est que le problème vient de ta configuration, puisque ça marche bien chez moi, chez Cosmos70 et chez Marc37, au moins. Et divers versions de Windows, y compris Windows 10.

Dans mon petit code, j'ai ajouté une ligne pour savoir comment la fonction se termine. Le message s'affiche lorsque la fonction est terminée (et lorsque le contenu du mémo est supposé être chargé), avec l'affichage de la valeur de res%:
Code:
dim res%, url$, mot$
memo 1 : full_space 1 : bar_both 1
dll_on "KGF.dll"
mot$="élève"
url$="http://www.systranet.com/fr/dictionary/french-english/"+mot$+"?"
res%=DLL_call3("GetHtmlFromURL",adr(url$),handle(1),1)
message "Terminé - res%="+str$(res%)
end
Chez moi, ça affiche "0".
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Pedro Alvarez

avatar

Nombre de messages : 1069
Date d'inscription : 19/01/2014

MessageSujet: Problème avec "DownloadFile".   Ven 4 Déc 2015 - 13:28

Bonjour.

Je viens de tester ton dernier code.
Eh bien, surprise, le message indiquant le résultat ne s'affiche même pas !

il semblerait que la fonction de  KGF soit bloquée.

Même après un nettoyage complet avec CCleaner !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème avec "DownloadFile".   Ven 4 Déc 2015 - 13:41

La fonction n'est pas bloquée. Ce qui est bloqué, c'est l'accès internet pour l'URL en question, et la DLL attend tout simplement que l'accès se fasse.

Fais un essai avec les fonctions WB_xxx: crée un browser, place-la dans une form, navigue vers ton URL, puis utilise WB_HtmlToMemo pour récuperer le code HTML.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Pedro Alvarez

avatar

Nombre de messages : 1069
Date d'inscription : 19/01/2014

MessageSujet: Problème avec "DownloadFile".   Ven 4 Déc 2015 - 13:55

Bonjour.

J'ai donc testé en utilisant un objet WB, et tout fonctionne parfaitement.

Code:
dll_on "kgf"

dim wb%, res%, url$

maximize 0
memo 1
top 1,150
width 1,800
height 1,800
bar_both 1

wb%=dll_call1("WBCreate",handle(0))
res%=dll_call4("WBLocate",0,0,100,100)

url$="http://www.systranet.com/fr/dictionary/french-english/élève?"

res%=dll_call2("WB_Url",wb%,adr(url$))
pause 1000

' res%=dll_call2("WB_CopyToMemo",wb%,handle(1))
res%=dll_call2("WB_HtmlToMemo",wb%,handle(1))
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème avec "DownloadFile".   Ven 4 Déc 2015 - 14:05

Bien. Ceci prouve que tu as un blocage au niveau d'un port internet. Avec les fonctions WB_xxx, tu passes en fait par le noyau d'Internet Explorer, en utilisant les réglages de sécurité de ce dernier. Alors que la fonction GetHtmlFromURL utilise l'API de Windows, supposant que les ports soient accessibles. Vérifie par rapport à ton pare-feu, anti-virus etc.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Contenu sponsorisé




MessageSujet: Re: Problème avec "DownloadFile".   

Revenir en haut Aller en bas
 
Problème avec "DownloadFile".
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [/résolu] problème avec java à l'instalation :-/
» Problème avec Java
» [Résolu] problème avec avira
» Problème avec décodeur Tv
» problème avec Outlook

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC :: PANORAMIC :: A l'aide!-
Sauter vers: