FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC

Développement d'applications avec le langage Panoramic
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  
Derniers sujets
» Planétarium virtuel.
par Pedro Alvarez Aujourd'hui à 16:57

» Roues dentées
par jean_debord Aujourd'hui à 10:40

» Attention arnaque !
par mindstorm Jeu 19 Juil 2018 - 19:18

» Qui fait quoi ?
par silverman Mer 18 Juil 2018 - 15:21

» ITEM_SELECT N,L pour synedit
par silverman Mer 18 Juil 2018 - 15:20

» Boussole
par jean_debord Mer 18 Juil 2018 - 11:06

» Roue à n faces
par Marc Dim 15 Juil 2018 - 22:16

» Exemple d'une nouvelle version d'un GRID
par Jean Claude Ven 13 Juil 2018 - 10:32

» Une simple question
par Oscaribout Sam 7 Juil 2018 - 23:20

» BUG sur l'objet TAB
par Jack Sam 7 Juil 2018 - 21:12

» Monopoly moderne
par jjn4 Sam 7 Juil 2018 - 15:06

» Récapitulatif ludothèque panoramic jjn4
par jjn4 Ven 6 Juil 2018 - 17:41

» Lignes ondulées
par JL35 Ven 6 Juil 2018 - 17:39

» bug off_activate 0 : sans d'effet
par silverman Ven 6 Juil 2018 - 13:02

» Position des objets d'un conteneur dans FBPano et Panoramic
par Navigateur Ven 6 Juil 2018 - 12:59

Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Juillet 2018
LunMarMerJeuVenSamDim
      1
2345678
9101112131415
16171819202122
23242526272829
3031     
CalendrierCalendrier

Partagez | 
 

 Problème d'affichage de 'form'.

Aller en bas 
AuteurMessage
Pedro Alvarez

avatar

Nombre de messages : 1104
Date d'inscription : 19/01/2014

MessageSujet: Problème d'affichage de 'form'.   Ven 4 Sep 2015 - 20:14

Bonsoir.

Je me demande pourquoi la form 0 ne remplit pas complètement l'écran, avec le code ci-dessous.
Je suis sous Windows 10 (résolution de 1600x900).

Une bordure désagréable apparaît sur les côtés gauche et droit.

L'utilisation de 'res% = DLL_call6("ChangeWindowSize...' ne change rien.


Merci de votre aide.


Code:
dim l%,h%

l%=screen_x
h%=screen_y

message str$(l%)+" "+str$(h%)

top 0,0
left 0,0
width 0,l%
height 0,h%
full_space 0
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
papydall

avatar

Nombre de messages : 5980
Age : 67
Localisation : Moknine (Tunisie) Entre la chaise et le clavier
Date d'inscription : 03/03/2012

MessageSujet: Re: Problème d'affichage de 'form'.   Ven 4 Sep 2015 - 20:36

Comme tu utilises FULL_SPACE 0, tu n’as pas besoin de
Code:
 top 0,0
left 0,0
width 0,l%
height 0,h%

Vire ces lignes et voie ce que ça donne.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://papydall-panoramic.forumarabia.com/
Pedro Alvarez

avatar

Nombre de messages : 1104
Date d'inscription : 19/01/2014

MessageSujet: Problème d'affichage de 'form'.   Ven 4 Sep 2015 - 20:40

Bonsoir.

Je confirme le fait.

D'ailleurs, une simple ligne 'full_space 0' affiche également une bordure désagréable.

La largueur de la form est de 1594 pixels, alors que la résolution écran est de 1600 pixels !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
papydall

avatar

Nombre de messages : 5980
Age : 67
Localisation : Moknine (Tunisie) Entre la chaise et le clavier
Date d'inscription : 03/03/2012

MessageSujet: Re: Problème d'affichage de 'form'.   Ven 4 Sep 2015 - 20:43

Rien de désagréable sous W7!
J'ai la même résolution que toi (1600 / 900) et pas de bordure désagréable.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://papydall-panoramic.forumarabia.com/
Jean Claude

avatar

Nombre de messages : 5527
Age : 64
Localisation : 83 Var
Date d'inscription : 07/05/2009

MessageSujet: Re: Problème d'affichage de 'form'.   Ven 4 Sep 2015 - 20:48

J'en ai parlé sur le post W10.

Les bordures sous W10 font 8 pixels, comme sous W8, mais elles sont transparentes ce qui les rends invisibles.
On ne peut rien y faire.

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Klaus

avatar

Nombre de messages : 11088
Age : 69
Localisation : Ile de France
Date d'inscription : 29/12/2009

MessageSujet: Re: Problème d'affichage de 'form'.   Ven 4 Sep 2015 - 21:53

Sauf avec border_hide. Là, il n'y a plus de bordures, même pas d'un seul pixel.

On le voit bien en plaçant un picture dans form 0, avec full_space sur le picture, puis en traçant un rectangle aux dimensions maximales:
Code:
label fin
border_hide 0
top 0,30 : left 0,10
on_click 0,fin
picture 1 : full_space 1
2d_target_is 1
' 2d_pen_width 4
2d_rectangle 0,0,width(1),height(1)
on_click 1,fin
end
fin:
terminate
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://klauspanoramic.comxa.com/index.html
Pedro Alvarez

avatar

Nombre de messages : 1104
Date d'inscription : 19/01/2014

MessageSujet: Problème d'affichage de 'form'.   Sam 5 Sep 2015 - 8:00

Bonjour.

Un grand merci Klaus.
En effet, je n'avais pas penser à utiliser 'border_hide'.
C'est nettement mieux maintenant, l'écran n'affichant plus de bordure désagréable.

Bonne journée.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Problème d'affichage de 'form'.   

Revenir en haut Aller en bas
 
Problème d'affichage de 'form'.
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Problème d'affichage dans FORM
» Garmin Nüvi 1340 problème d'affichage
» Problème d'affichage sous FireFox [Résolu]
» format des BMP sur Garmin 3490 : pas d'affichage
» [résolu]Affichage des noms de villes nuvi 1490

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC :: PANORAMIC :: A l'aide!-
Sauter vers: