FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC

Développement d'applications avec le langage Panoramic
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  
Derniers sujets
» Mah-Jong européen new-look
par jjn4 Aujourd'hui à 15:48

» KGF.dll - demandes ou suggestions de modifications ou ajouts
par pascal10000 Aujourd'hui à 13:46

» a l'aide klaus
par Minibug Aujourd'hui à 11:42

» KGF_dll - nouvelles versions
par Minibug Aujourd'hui à 1:48

» bug SYNEDIT_TARGET_IS_OBJECT
par Jack Aujourd'hui à 0:16

» Jukebox : Serge Reggiani
par papydall Sam 9 Déc 2017 - 5:58

» Ecouter la radio fm sur votre pc
par pascal10000 Sam 9 Déc 2017 - 3:42

» anomalie
par Klaus Sam 9 Déc 2017 - 3:21

» hommage
par Jicehel Ven 8 Déc 2017 - 11:29

» Logiciel de soutien scolaire en langues.
par Pedro Alvarez Ven 8 Déc 2017 - 10:43

» carte son
par Klaus Ven 8 Déc 2017 - 2:37

» API Windows
par Klaus Jeu 7 Déc 2017 - 21:03

» mise a jour calculatrice
par joeeee2017 Mer 6 Déc 2017 - 22:19

» j'ai un petit problème
par JL35 Mer 6 Déc 2017 - 21:58

» source vumetre avec delphi
par Klaus Mar 5 Déc 2017 - 23:22

Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Décembre 2017
LunMarMerJeuVenSamDim
    123
45678910
11121314151617
18192021222324
25262728293031
CalendrierCalendrier

Partagez | 
 

 Bug quand on ne sélectionne rien dans un list avec item_inde

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
jimx78

avatar

Nombre de messages : 240
Age : 26
Localisation : Yvelines
Date d'inscription : 24/05/2010

MessageSujet: Bug quand on ne sélectionne rien dans un list avec item_inde   Jeu 3 Sep 2015 - 21:16

Salut,

Y a t'il un bug ou y a t'il une méthode quand on ne sélectionne rien dans un list avec item_index$(N) ?

Normalement la doc indique que si rien n'est sélectionner, cela dois afficher ""

Merci de votre aide

Code:
list 1

item_add 1,"c'est la ligne 1"
item_add 1,"c'est la ligne 2"

if item_index$(1) = "" then message "Vous n avais rien selectionner"

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean Claude

avatar

Nombre de messages : 5086
Age : 63
Localisation : 83 Var
Date d'inscription : 07/05/2009

MessageSujet: Re: Bug quand on ne sélectionne rien dans un list avec item_inde   Jeu 3 Sep 2015 - 21:28

Essai plutôt comme ça, Jimx78:
Code:
label clic

list 1
item_add 1,"c'est la ligne 1"
item_add 1,"c'est la ligne 2"
on_click 1,clic

END

clic:
  if item_index(1)=0 then message "Vous n'avez rien selectionner"
return

Tu as 2 mots clés différent à ta disposition: item_index(N) pour retourner le numéro de ligne et item_index$(N) pour retourner le contenu de la ligne sous forme de string.
A+


Dernière édition par Jean Claude le Jeu 3 Sep 2015 - 21:34, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jimx78

avatar

Nombre de messages : 240
Age : 26
Localisation : Yvelines
Date d'inscription : 24/05/2010

MessageSujet: Re: Bug quand on ne sélectionne rien dans un list avec item_inde   Jeu 3 Sep 2015 - 21:33

merci, j'ai remarquer que quand on ne pratique pas, on perd avec le temps Crying or Very sad

Pas grave je m'y remet, merci jean claude
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Bug quand on ne sélectionne rien dans un list avec item_inde   

Revenir en haut Aller en bas
 
Bug quand on ne sélectionne rien dans un list avec item_inde
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [résolu]Plusieurs soucis très gênants!!
» [Resolu] Bannière avec lien dans une signature
» separation loco
» BlondieAlexee : i know you want me :)
» Cela revient-il finalement plus cher/equivalent ?

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC :: PANORAMIC :: A l'aide!-
Sauter vers: