FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC

Développement d'applications avec le langage Panoramic
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  
Derniers sujets
» Demande urgente en maths.
par JL35 Aujourd'hui à 22:26

» Compilateur FBPano
par jean_debord Aujourd'hui à 11:24

» Problème de math
par braveen Aujourd'hui à 10:53

» A propos des attributs de fichier
par papydall Hier à 14:33

» Problème de math
par Marc37 Sam 21 Oct 2017 - 23:04

» I Love You
par papydall Sam 21 Oct 2017 - 19:22

» Un petit "coucou" à tous les Panoramiciens !
par mindstorm Sam 21 Oct 2017 - 17:06

» MARK_ON déclenche un événement ON_CLICK à la place de ...
par Jean Claude Mer 18 Oct 2017 - 18:08

» mise a jour calculatrice
par joeeee2017 Mer 18 Oct 2017 - 15:57

» [solved] 3D_LINE How to ?
par Jicehel Mer 18 Oct 2017 - 11:01

» Convertisseur de base 10 de 2 à 36
par gigi75 Mar 17 Oct 2017 - 18:49

» calculatrice avec touches movibles
par joeeee2017 Dim 15 Oct 2017 - 1:11

» CORTANA
par gigi75 Sam 14 Oct 2017 - 16:32

» Calculatrice
par Jean Claude Sam 14 Oct 2017 - 12:30

» KGF_dll - nouvelles versions
par Klaus Mar 10 Oct 2017 - 18:49

Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Octobre 2017
LunMarMerJeuVenSamDim
      1
2345678
9101112131415
16171819202122
23242526272829
3031     
CalendrierCalendrier

Partagez | 
 

 J'ai perdu la couleur !!!

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Froggy One

avatar

Nombre de messages : 393
Date d'inscription : 06/01/2012

MessageSujet: J'ai perdu la couleur !!!   Mar 16 Déc 2014 - 0:13

Bonsoir à tous !

Voici un terrain dont toutes les cases devraient s'afficher pareilles, or les quatre dernières colonnes restent blanches !?!

Code:
width 0,656:height 0,520
DIM x,y
DIM nbElt:nbElt=40
DIM bordGauche,bordDroit,bordHaut,bordBas,destinationX,destinationY
DIM posX(nbELt),posY(nbElt),recherche(nbElt,nbElt)
DIM type(nbElt),static(nbElt),dur(nbElt),namTypElt$(6)
DATA "Personnage","Véhicule","Chemin","Obstacle","Bâtiment","Item"

LABEL CreaTile,CreatElt,DestrElt,ExplorEnvt

gosub CreaTile



END

  CreaTile:

  for y=0 to 14
      for x=0 to 19
          2d_fill_color 240,240,0
          2d_rectangle x*32,y*32,(x+16)*32,(y+16)*32
          2d_fill_color 0,0,0:2d_fill_diagonal_up
          2d_rectangle x*32,y*32,(x+16)*32,(y+16)*32
      next x
  next y
  




  RETURN

  CreatElt:





  RETURN
  
  DestrElt:





  RETURN
  
  explorEnvt:





  RETURN

Je précise bien sûr que c'est un tout petit début de code, d'où les vides, mais ce n'est pas ça qui m'embête. J'utilise la version 0926i2 mais c'est pareil sous d'autres.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://gaeldwest.wordpress.com
papydall

avatar

Nombre de messages : 5551
Age : 67
Localisation : Moknine (Tunisie) Entre la chaise et le clavier
Date d'inscription : 03/03/2012

MessageSujet: Re: J'ai perdu la couleur !!!   Mar 16 Déc 2014 - 1:14

Salut Froggy One.

Froggy One a écrit:
Voici un terrain dont toutes les cases devraient s'afficher pareilles, or les quatre dernières colonnes restent blanches !?!


Lignes 22 et 24   (le 16 doit être changé en 20)  comme ceci :

Code:

 2d_rectangle x*32,y*32,(x+20)*32,(y+20)*32
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://papydall-panoramic.forumarabia.com/
Froggy One

avatar

Nombre de messages : 393
Date d'inscription : 06/01/2012

MessageSujet: re   Mar 16 Déc 2014 - 11:14

Merci Papydall ! Je ne devrais peut-être plus coder après 20h... Laughing
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://gaeldwest.wordpress.com
Froggy One

avatar

Nombre de messages : 393
Date d'inscription : 06/01/2012

MessageSujet: Re   Mar 16 Déc 2014 - 11:18

Mais non, changer le 16 en 20 va juste donner des carrés de 20*20 au lieu de 16*16 et le problème demeure...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://gaeldwest.wordpress.com
mimic

avatar

Nombre de messages : 75
Localisation : france
Date d'inscription : 02/09/2009

MessageSujet: Re: J'ai perdu la couleur !!!   Mar 16 Déc 2014 - 13:25

Bonjour,

Une remarque, en enlevant les instructions :

2d_fill_color 0,0,0:2d_fill_diagonal_up.

Les cases sont toutes jaunes…
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jicehel

avatar

Nombre de messages : 5858
Age : 45
Localisation : 77500
Date d'inscription : 19/04/2011

MessageSujet: Re: J'ai perdu la couleur !!!   Mar 16 Déc 2014 - 14:01

J'ai jetté un coup d'oeil sur ton programme mais je ne comprends pas très bien où tu veux en venir. Tu dessines de 16 pixels et après tu redessines dessus ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Yannick

avatar

Nombre de messages : 7994
Age : 46
Localisation : Bretagne
Date d'inscription : 15/02/2010

MessageSujet: re   Mar 16 Déc 2014 - 15:17

@ Froggy one,

Tes carrés ne font pas 16x16px mais 32x32px
La solution de Papydall est bonne et fonctionne.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Froggy One

avatar

Nombre de messages : 393
Date d'inscription : 06/01/2012

MessageSujet: Re   Mar 16 Déc 2014 - 17:14

@Ygeronimi : en effet !!!
@ Jicehel : ben oui, j'ai voulu faire des traits noirs dans des carrés jaunes pleins. Il est vrai que j'aurais pu colorer le FORM. Bon, je vais reprendre des vitamines, moi. En tous cas merci à tous !!!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://gaeldwest.wordpress.com
Contenu sponsorisé




MessageSujet: Re: J'ai perdu la couleur !!!   

Revenir en haut Aller en bas
 
J'ai perdu la couleur !!!
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [résolu]identifiant perdu à chaque connection
» Couleur : traitement par Teinte, Saturation, Luminosité
» des photos en couleur de la 14-18
» perdu mon emploi... acceptée au chomage... trouvé un emploi (tout ca en 1 semaine!)
» J'ai perdu le fusible de l'allume-cigare !

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC :: PANORAMIC :: Vos sources, vos utilitaires à partager-
Sauter vers: