FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC

Développement d'applications avec le langage Panoramic
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  
Derniers sujets
» Interception des touches quel que soit l'objet Panoramic
par Minibug Hier à 21:32

» Une copie de Panoramic Editeur
par Jean Claude Hier à 21:02

» KGF_dll - nouvelles versions
par Klaus Hier à 0:13

» Animation 3D 4 faces avec le logo de Panoramic
par Marc Hier à 0:07

» Animation 3D 2 faces avec le logo de Panoramic
par Minibug Sam 26 Mai 2018 - 20:01

» [RESOLU] pas de caractères accentués dans resource hacker
par Minibug Ven 25 Mai 2018 - 13:50

» Panoramic et la 3D.
par Pedro Alvarez Ven 25 Mai 2018 - 9:34

» Problème mathématique en 3D
par Marc Jeu 24 Mai 2018 - 18:24

» Nouvelle version 0.33
par jean_debord Jeu 24 Mai 2018 - 9:02

» Reprise du développement et de la documentation
par Fredisland Jeu 24 Mai 2018 - 7:14

» Objet 3D_PLANE, réalisation d'un dé en 3D
par Marc Mar 22 Mai 2018 - 0:33

» Cacher la barre des tâches
par Klaus Lun 21 Mai 2018 - 21:27

» Une "base de connaissance" - pour jouer ou plus si affinité
par Minibug Lun 21 Mai 2018 - 10:29

» quel est ce comportement de Panoramic_editor
par Oscaribout Lun 21 Mai 2018 - 0:22

» Des FORM(s) Colorés
par Jean Claude Dim 20 Mai 2018 - 20:58

Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Mai 2018
LunMarMerJeuVenSamDim
 123456
78910111213
14151617181920
21222324252627
28293031   
CalendrierCalendrier

Partagez | 
 

 Problème avec 'on_error_goto'.

Aller en bas 
AuteurMessage
Pedro Alvarez

avatar

Nombre de messages : 1003
Date d'inscription : 19/01/2014

MessageSujet: Problème avec 'on_error_goto'.   Dim 28 Sep 2014 - 15:08

Bonjour.

Voici encore un estrait du code de mon programme, où les erreurs ne sont pas détectées par 'on_error_goto'.

Toutes les variables étant déclarées en début de programme.

Sauf z99%, car il s'agit d'une erreur d'écriture.

De même, l'oubli d'une parenthèse à la din de la ligne x%=... n'est pas détectée.

Par contre, si je désactive 'on_error_goto', les deux erreurs sont bien détectées !!


Code:
      operateur$="+"
                z99%=instr(c$,"+")
                if zz99%=0
                  zz99%=instr(c$,"-")
                  operateur$="-"
                end_if
                if zz99%=0
                  zz99%=instr(c$,"*")
                  operateur$="*"
                end_if
                if zz99%=0
                  zz99%=instr(c$,"/")
                  operateur$="/"
                end_if
                x%=val(left$(c$,zz99%-1)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean Claude

avatar

Nombre de messages : 5377
Age : 64
Localisation : 83 Var
Date d'inscription : 07/05/2009

MessageSujet: Re: Problème avec 'on_error_goto'.   Dim 28 Sep 2014 - 16:33

@Pédro,
Ton code est incomplet, on n'a pas ON_ERROR_GOTO, ni le label sur lequel il dirige le programme.
Les erreurs ne sont pas signalées, c'est normal car c'est à toi de programmer ce que que le programme doit faire en cas d'erreur.
Il faut que tu ais un sous_programme "ON_ERROR_GOTO erreur" qui traite les erreurs en utilisant les commandes ERROR_LINE, ERROR_NUMBER, ERROR_TYPE$
Et là tu verras que les erreurs sont traitées.
Si ton sous programme "ON_ERROR_GOTO erreur" est terminate, on peut dire que ON_ERROR_GOTO ne sert à rien (dans ce cas précis)

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Pedro Alvarez

avatar

Nombre de messages : 1003
Date d'inscription : 19/01/2014

MessageSujet: Problème avec 'on_error_goto'.   Dim 28 Sep 2014 - 16:41

Bonjour.

J'ai bien dit plus haut qu'il s'agissait d'une portion de mon code, qui comporte à ce jour plus de 31.400 lignes.

Tout ce que tu écris est bien prévu.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean Claude

avatar

Nombre de messages : 5377
Age : 64
Localisation : 83 Var
Date d'inscription : 07/05/2009

MessageSujet: Re: Problème avec 'on_error_goto'.   Dim 28 Sep 2014 - 19:17

Bon,  j'ai fait un petit bout de programme pour mettre en défaut ON_ERROR_GOTO avec les 2 erreurs que tu décries et je n'y suit pas parvenu, çà marche normalement.

Mais j'ai un comportement bizarre, je cherche pourquoi avant de publier.

A+

PS: n'oublie pas que le programme cesse de fonctionner à la première erreur, donc il ne signalera pas la seconde.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean Claude

avatar

Nombre de messages : 5377
Age : 64
Localisation : 83 Var
Date d'inscription : 07/05/2009

MessageSujet: Re: Problème avec 'on_error_goto'.   Dim 28 Sep 2014 - 20:30

Bon, je livre le code d'essai sur lequel j'avais un doute.

Code:
label erreur
label start,start2
dim a$ : a$="1"
dim nb_erreur%,limite_error% : limite_error%=2
' dim c%
error_french
 on_error_goto erreur
gosub start
END
rem ============================================================================
start:
  message "BONJOUR"
  if a$="F" then terminate
  c%=val(a$) : nb_erreur%=nb_erreur%+1 : ' vu que c% n'est pas déclarée
  if nb_erreur%=c% then message "nb_erreur%=valeur de a$" : caption 0,a$
start2:
  nb_erreur%=nb_erreur%+1 :' vu que c% n'est TOUJOURS pas déclarée
  if c%=nb_erreur% then message "c%=nb_erreur%" : ' erreur détectée 2 fois (Normal, vu le traitement au label erreur)
  message "A+"
return
' ------------------------------------------------------------------------------
erreur:
message "Erreur détectée: N°"+str$(ERROR_NUMBER)+" "+ERROR_TYPE$+" à la Ligne "+str$(ERROR_LINE)+chr$(13)+chr$(13)+"Cliquez encore pour sortir"
  if nb_erreur%>limite_error% then terminate
  gosub start2
return

Quoi dire, je ne vois pas de problème.

Le seul point qui pose problème, serait que si à la ligne 25 je change gosub start2 par gosub start le programme boucle (Goto/Return) et donc n'annonce jamais la deuxième erreur. Mais ce fonctionnement me parait normal...

Désolé Pédro, je ne peux pas t'aider plus.

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jean Claude

avatar

Nombre de messages : 5377
Age : 64
Localisation : 83 Var
Date d'inscription : 07/05/2009

MessageSujet: Re: Problème avec 'on_error_goto'.   Dim 28 Sep 2014 - 20:48

J'ai tout de même une réflexion concernant ON_ERROR_GOTO,

A mon avis, cette fonction ne doit pas être confondue entre les erreurs de codage et la détection d'erreur, prévues, à l'exécution du programme.
Je veux dire par là, que cette fonction est plus adaptée pour dire au programme ce qu'il doit faire en cas d'erreur (car cette erreur est prévue par le programmeur). Mais cette fonction, à mon avis, n'est pas adaptée (prévue) pour les erreurs de codage.

Donc pendant le codage, il faut désactiver "ON_ERROR_GOTO" pour permettre à Panoramic_Editor de faire son travail de détection d'erreur, et ensuite réactiver.

Je ne suis pas certain d'être très clair, il faudrait que je trouve un exemple valide.

JL35 doit savoir de quoi je parle, on en a déjà parlé. Une histoire d'erreur, volontaire ou prévue.... Mais je n'arrive pas à me souvenir...
Stop JL35, je t'entend dire "C'est qui le vieux..." Very Happy

A+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Problème avec 'on_error_goto'.   

Revenir en haut Aller en bas
 
Problème avec 'on_error_goto'.
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [/résolu] problème avec java à l'instalation :-/
» Problème avec Java
» [Résolu] problème avec avira
» Problème avec décodeur Tv
» problème avec Outlook

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC :: PANORAMIC :: A l'aide!-
Sauter vers: